Uploaded image for project: 'ui-users'
  1. ui-users
  2. UIU-507

TAMU - error message when accessing a user that has no permissions

    XMLWordPrintable

Details

    • Core: F - Sprint 60, Core: F - Sprint 61
    • 5
    • Prokopovych

    Description

      The following is the steps to follow to reproduce the error. Note this was reported by TAMU.

      1) I create a single user record using the /users endpoint. This is intended to be a record for a public user, not someone who would ever log into folio.
      2) I search for the record in the users UI and find it.
      3) I click on the record in the list to pull up the details and I get this error: ERROR: in module @folio/users, operation GET on resource 'permissions' failed, saying: No user found by id 4008adb8-80fe-4fba-9bf5-7294a31d0797. The error message goes away if I create a permissions record for that user. I create it with a null permissions array. Once I do that, I no longer get the error message when I pull up the record details.”

      Attached is a screencast of the issue. So I guess the question is : Are permissions required even though most patrons loaded/created will never be assigned permissions?

      TestRail: Results

        Attachments

          Issue Links

            Activity

              People

                zburke Zak_Burke
                kgambrell Khalilah Gambrell
                Anne L. Highsmith Anne L. Highsmith
                Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                  Created:
                  Updated:
                  Resolved:

                  TestRail: Runs

                    TestRail: Cases