Uploaded image for project: 'ui-users'
  1. ui-users
  2. UIU-2081

Link to absent user should lead to user-readable message

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • P2
    • Resolution: Done
    • None
    • 6.0.4, 6.0.5, 6.1.0
    • None
    • Prokopovych - Sprint 111, Prokopovych - Sprint 112, Prokopovych - Sprint 113
    • 5
    • Prokopovych
    • R1 2021 Bug Fix

    Description

      When processing link to absent users (like https://folio-snapshot.dev.folio.org/users/view/df7f4993-8c14-4a0f-ab63-93975ab01c76)

      • the browser alert dialog with user-unfriendly message is displayed
      • after closing this dialog, the page shows eternal "loading" state
      • "x" control for closing the page doesn't work

      Steps to Reproduce:

      1. Go to https://folio-snapshot.dev.folio.org/users/view/df7f4993-8c14-4a0f-ab63-93975ab01c76

      Expected Results:

      • user-friendly message about absence of such user

      Actual Results:

      • browser alert: "Response:¬†ERROR: in module @folio/users, operation GET on resource 'selUser' failed, saying: Not found"
      • after closing the alert - "Loading" indicator spins
      • click "X" button does not close the overlay

      Note:
      Similar behavior when opening loan page like https://folio-snapshot.dev.folio.org/users/df7f4993-8c14-4a0f-ab63-93975ab01c76/loans/view/cf23adf0-61ba-4887-bf82-956c4aae2260

      TestRail: Results

        Attachments

          Issue Links

            Activity

              People

                mpk35 Michal Kuklis
                mozolev Alex Mozolev
                Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                  Created:
                  Updated:
                  Resolved:

                  TestRail: Runs

                    TestRail: Cases