Uploaded image for project: 'ui-users'
  1. ui-users
  2. UIU-1837

User search function is not working as intended

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: TBD
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
    • Template:
      Standard Bug Write-Up Format
    • Development Team:
      None

      Description

      https://github.com/folio-org/ui-users/blob/master/test/bigtest/network/config.js#L142-L160

      The `term` and `field` properties do not exist on `cqlParser.tree` so querying a search will always return all users. The way the tests were written previously, it would search for 'a' (betting against the small chance that none of the random names will have 'a') to check if more than 0 users are returned.

      I rewrote the tests to seed a user with a specific name and the test checks to see if that particular user exists which is a better way of testing the search function. I commented out the test suite for now until the search function is fixed: https://github.com/folio-org/ui-users/blob/f9f4aeba8d5ac159de3dfc346597c019c39d719b/test/integration/users-status-filter.test.js#L48-L59

        TestRail: Results

          Attachments

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              minkimcello Min Kim
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  TestRail: Runs

                    TestRail: Cases