Uploaded image for project: 'ui-users'
  1. ui-users
  2. UIU-1596

Users filtering by patron group fails if group contains comma or period

    XMLWordPrintable

    Details

    • Template:
    • Sprint:
      Core: F - Sprint 86, Core: F - Sprint 87
    • Story Points:
      3
    • Development Team:
      Prokopovych

      Description

      Steps to repro:

      1. Log into snapshot
      2. Go to Settings > Users and create a patron group containing non-alpha numeric characters (e.g. UC Stu/College Quarter)
      3. Go to Users and assign this patron group to a user
      4. Now use filters to filter by that patron group

      Actual result: No results

      Expected: Should return matching user

      Additional info:

      • If you go into settings and remove the non-alphanumeric characters from the patron group description, the filter works fine again
      • I tried including a number in a patron group description and that didn't cause problems

      Example from BugFest environment:

      For example, filter for UC Stu/College Quarter
      no results
      But, search for George Wickham, barcode 12251798
      He has that patron group assigned.

        TestRail: Results

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                mpk35 Michal Kuklis
                Reporter:
                pwanninger Patty Wanninger
                Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved:

                    TestRail: Runs

                      TestRail: Cases