Uploaded image for project: 'ui-users'
  1. ui-users
  2. UIU-1534

BugFest: User with Permission Set with Many Permission Seeing No Apps

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: P2
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
    • Template:

      Description

      Steps to repro:

      1. Logged into bugfest https://bugfest.folio.ebsco.com/ with folio user
      2. In Settings > Users, I created a permission set called "Circulation, Users, Inventory (including settings) - BROKEN PERMISSION SET". It has all permissions in Requests, Users, Inventory, Check in and Check out plus lots of related settings permissions
      3. In Users, I created a user (cboerema/foliotest)
      4. I gave that user the new permission set
      5. Logged out
      6. Logged back in as cboerema

      Expected: Should see lots of apps in the nav bar (e.g. Users, Inventory, Check in, Check out, Settings, Requests)

      Actual: Nothing appears in nav bar

      Additional info:

      • I was able to create another user and, when I directly added permissions to that user (instead of via permission set) I was able to see apps when I logged in
      • I created a different permission set with many of the same permissions and, when I assigned it to a different user, I was able to see apps when I logged in
      • Maybe there is just some permissions which, if added to a set, causes the apps to disappear

        TestRail: Results

          Attachments

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              cboerema Cate Boerema
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  TestRail: Runs

                    TestRail: Cases