Uploaded image for project: 'ui-search'
  1. ui-search
  2. UISE-65

Yarn lint won't run: Configuration for rule "jsx-a11y/anchor-has-content" is invalid

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: P2
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 1.2.0
    • Labels:
    • Template:

      Description

      $ yarn lint
      yarn run v1.3.2
      $ eslint .
      /Users/mike/git/folio/stripes/node_modules/eslint-config-stripes/node_modules/eslint-config-airbnb/rules/react-a11y.js:
      	Configuration for rule "jsx-a11y/anchor-has-content" is invalid:
      	Value "[object Object]" no (or more than one) schemas match.
      
      Referenced from: airbnb
      Referenced from: stripes
      Referenced from: /Users/mike/git/folio/stripes/ui-search/.eslintrc
      

      This does not affect ui-users, so seems to be something local to ui-search.

        TestRail: Results

          Attachments

            Activity

              People

              Assignee:
              mike Mike Taylor
              Reporter:
              mike Mike Taylor
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 1 hour
                  1h

                    TestRail: Runs

                      TestRail: Cases