Uploaded image for project: 'ui-plugin-find-instance '
  1. ui-plugin-find-instance
  2. UIPFI-77

increment stripes to v7

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed (View Workflow)
    • Priority: TBD
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 6.0.0
    • Labels:
      None
    • Template:
    • Sprint:
      Prokopovych - Sprint 124
    • Story Points:
      1
    • Development Team:
      Prokopovych

      Description

      Summary: Update dependencies to their @folio/stripes v7-compatible versions, including React v17, in your package.json file.

      1. bump your app's major version (e.g. from 6.2.0 to 7.0.0)
      2. update dev-dependencies
      3. update peer-dependencies
      // dev deps
          "@folio/stripes-components": "^10.0.0",
          "@folio/stripes-connect": "^7.0.0",
          "@folio/stripes-core": "^8.0.0",
          "@folio/stripes-final-form": "^6.0.0",
          "@folio/stripes-form": "^7.0.0",
          "@folio/stripes-smart-components": "^7.0.0",
          "@folio/stripes-util": "^5.0.0",
      
      // peer deps
          "@folio/stripes": "^7.0.0",
          "react": "^17.0.2",
          "react-dom": "^17.0.2",
          "redux-observable": "^1.2.0",
          "rxjs": "^6.6.3",
      

      NOTE: You will not be able to commit the above changes until Monday, September 13, 2021 when these changes are committed in the stripes-* repos. Until then, they will only be available on branches while we finalize the work. To test your app with these v7 changes before September 13, use the following:

      // dev deps
          "@folio/stripes-components": "folio-org/stripes-components#stripes-v7",
          "@folio/stripes-connect": "folio-org/stripes-connect#stripes-v7",
          "@folio/stripes-core": "folio-org/stripes-core#stripes-v7",
          "@folio/stripes-final-form": "folio-org/stripes-final-form#stripes-v7",
          "@folio/stripes-form": "folio-org/stripes-form#stripes-v7",
          "@folio/stripes-smart-components": "folio-org/stripes-smart-components#stripes-v7",
          "@folio/stripes-util": "folio-org/stripes-util#stripes-v7",
      
      // peer deps
          "@folio/stripes": "folio-org/stripes#stripes-v7",
          "react": "^17.0.2",
          "react-dom": "^17.0.2",
          "redux-observable": "^1.2.0",
          "rxjs": "^6.6.3",
      

        TestRail: Results

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                mpk35 Michal Kuklis
                Reporter:
                zburke Zak_Burke
                Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved:

                    TestRail: Runs

                      TestRail: Cases