Uploaded image for project: 'ui-orders'
  1. ui-orders
  2. UIOR-474

Orders: The UI does not communicate validation error when posting Order lines

    XMLWordPrintable

    Details

    • Template:
    • Sprint:
      ACQ Sprint 82
    • Development Team:
      Thunderjet

      Description

      We are having problems when saving POLs. It's happening on both Chrome and Firefox and on different computers, with different users (with Admin permissions).

      Sometimes it's possible to create a new order with a POL. We have not yet found any pattern when the error occurs and when it doesn't.

      Steps to reproduce
      1. Login to Chalmers' FOLIO (version 3.2)
      2. Go to Orders - New
      3. Choose template HBbokus and Save
      4. Add PO Line
      5. Fetch ISBN from Inventory with plus sign (this example 1027-3190) (Yes, not an actual ISBN)
      I make no other changes except for adding a Vendor Ref Number.
      Save

      Expected Result:
      To have the Server side validation error propagated to me in some way

      Actual Result:
      Get a red error message "Purchase order line not created"

        TestRail: Results

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                dennisbridges Dennis Bridges
                Reporter:
                ttolstoy Theodor Tolstoy
                Tester Assignee:
                Dennis Bridges Dennis Bridges
                Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved:

                    TestRail: Runs

                      TestRail: Cases