Uploaded image for project: 'ui-inventory'
  1. ui-inventory
  2. UIIN-735

The language filter does not follow ISO 639 and can not search on e.g. Swedish

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • P2
    • Resolution: Done
    • None
    • 1.13.0
    • Core: F - Sprint 74
    • 5
    • Prokopovych
    • Pointed assuming we can use existing data in module

    Description

      Overview: When implementing UIIN-596 then the language search was not fully implemented to support ISO 639.
      This is important for e.g. Chalmers and also for BNCF.

      Steps to reproduce:

      1. Login to FOLIO Snapshot, go to Inventory
      2. When looking in the Search and filter pane and the language filter is unfolded

      Expected result:
      The display looks like:

      • The language list is following the ISO 639 standardized nomenclature used to classify languages
      • The language list, has the languages listed in alphabetic order
      • When starting to type in the box, e.g. 'sw'
        • Then the list of languages gets to be narrowed down to:
          • Swahili
          • Swati
          • Swedish

      Actual result:

      even when there is an instance record with Language value Swedish:

      TestRail: Results

        Attachments

          Activity

            People

              mpk35 Michal Kuklis
              charlotte Charlotte Whitt
              Charlotte Whitt Charlotte Whitt
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                TestRail: Runs

                  TestRail: Cases