Uploaded image for project: 'ui-inventory'
  1. ui-inventory
  2. UIIN-713

Fix UX consistency issue. Instance. Empty data element populate a dash

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • P3
    • Resolution: Duplicate
    • None
    • None
    • Prokopovych

    Description

      Overview: The general UX idea is that empty data fields in the UI, in detailed view of a record, populate the label, and the empty state is displayed as a dash. In inventory, instance record, then the overall idea has been that when an element is empty, then the element is not displayed. But we have some inconsistency, with labels being displayed, but no data values.

      CW: will discuss this with MM-SIG 9/12/2019:
      a. follow general UX. All elements displayed in the UI. And empty values are populated with "-"
      b. only display elements, with label and value, if data is present

      Steps to reproduce:

      1. Login to FOLIO Snapshot, Go to Inventory, any given instance record
      2. Look at all empty data elements

      Expected results:
      If element label is populated then the empty value is shown by a dash ("-")

      Actual results:
      Some labels are displayed, and the data values are left empty, blank

      TestRail: Results

        Attachments

          Issue Links

            Activity

              People

                Unassigned Unassigned
                charlotte Charlotte Whitt
                Charlotte Whitt Charlotte Whitt
                Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                  Created:
                  Updated:
                  Resolved:

                  TestRail: Runs

                    TestRail: Cases