Uploaded image for project: 'ui-inventory'
  1. ui-inventory
  2. UIIN-1568

align dependency versions affected by Inventory's Optimistic Locking

    XMLWordPrintable

    Details

    • Type: Story
    • Status: Closed (View Workflow)
    • Priority: P2
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None
    • Template:
    • Sprint:
      CP: sprint 121
    • Story Points:
      2
    • Development Team:
      Core: Platform

      Description

      https://github.com/folio-org/ui-inventory/blob/master/package.json declares these dependencies:

      "okapiInterfaces": {
            "inventory": "10.10",
            "instance-storage": "7.0",
            "holdings-storage": "3.0 4.4",
            "item-storage": "8.0",
      

      These are mod-inventory-storage interfaces without optimistic locking.

      mod-inventory-storage will enable optimistic locking while switching to new major interface versions. ui-inventory needs to add these new versions to its dependencies.

      For details see

      https://wiki.folio.org/display/DD/Optimistic+locking+proposal
      https://issues.folio.org/browse/UXPROD-3089
      https://issues.folio.org/browse/FOLIO-3241

      Out of scope:

        TestRail: Results

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                mikhail.fokanov Mikhail Fokanov
                Reporter:
                julianladisch Julian Ladisch
                Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved:

                    TestRail: Runs

                      TestRail: Cases