Uploaded image for project: 'ui-eholdings'
  1. ui-eholdings
  2. UIEH-816

Improved Catastrophic Error Messaging

    XMLWordPrintable

    Details

    • Template:
    • Sprint:
      eHoldings Sprint 94, eHoldings Sprint 95
    • Story Points:
      3
    • Development Team:
      Spitfire

      Description

      As a librarian
      I want a valid reason for why I cannot access the eholdings app

      Background

      Currently when eholdings app is down, regardless of the reason, the UI displays an error message that the KB is not configured properly.

      Requirement

      When eholdings app is down then display the most applicable error message.

      Acceptance criteria

      Given I am on the eholdings app
      When the error is not due to API credential configuration OR eholdings app not being installed
      AND it is due to an exceeded API limit [Error 429]
      Then display an error message - [Unable to complete operation. HoldingsIQ API limit has been exceeded. Please contact your EBSCO Holdings IQ support contact.]

      Given I am on the eholdings app
      When the error is due to Holdings API being down
      Then display an error message - [eholdings app is unavailable at this time. If the problem persist please contact your FOLIO system administrator or visit EBSCO Connect [link to https://connect.ebsco.com].]

        TestRail: Results

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                kgambrell Khalilah Gambrell
                Reporter:
                kgambrell Khalilah Gambrell
                Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved:

                    TestRail: Runs

                      TestRail: Cases