Uploaded image for project: 'ui-data-import'
  1. ui-data-import
  2. UIDATIMP-339

platform-complete webpack build failure with data-import 1.7.0

    XMLWordPrintable

    Details

    • Template:
    • Sprint:
      EPAM BatchLoader Sprint 31
    • Story Points:
      1
    • Development Team:
      Folijet

      Description

      There is a webpack build failure for the Q4 release of platform-complete. It appears specially related to ui-data-import-1.7.0.

      [1m[31mERROR in ./node_modules/@folio/data-import/src/components/ProfileAssociator/ProfileAssociator.js
      Module not found: Error: Can't resolve '@folio/stripes-smart-components' in '/home/jenkins/workspace/platform-complete_bulk-q4-update/node_modules/@folio/data-import/src/components/ProfileAssociator'
       @ ./node_modules/@folio/data-import/src/components/ProfileAssociator/ProfileAssociator.js 18:0-78 36:15-23 37:16-24 144:15-32
       @ ./node_modules/@folio/data-import/src/components/ProfileAssociator/index.js
       @ ./node_modules/@folio/data-import/src/components/index.js
       @ ./node_modules/@folio/data-import/src/index.js
       @ ./node_modules/stripes-config.js
       @ ./node_modules/@folio/stripes-core/src/App.js
       @ ./node_modules/@folio/stripes-core/src/index.js
       @ multi @folio/stripes-components/lib/global.css ./node_modules/@folio/stripes-core/src/index[39m[22m
      [1m[31mERROR in ./node_modules/@folio/data-import/src/routes/ViewAllLogs/ViewAllLogsFilters.js
      Module not found: Error: Can't resolve '@folio/stripes-smart-components' in '/home/jenkins/workspace/platform-complete_bulk-q4-update/node_modules/@folio/data-import/src/routes/ViewAllLogs'
       @ ./node_modules/@folio/data-import/src/routes/ViewAllLogs/ViewAllLogsFilters.js 11:0-82 91:28-42 108:28-43
       @ ./node_modules/@folio/data-import/src/routes/ViewAllLogs/ViewAllLogs.js
       @ ./node_modules/@folio/data-import/src/routes/ViewAllLogs/index.js
       @ ./node_modules/@folio/data-import/src/index.js
       @ ./node_modules/stripes-config.js
       @ ./node_modules/@folio/stripes-core/src/App.js
       @ ./node_modules/@folio/stripes-core/src/index.js
       @ multi @folio/stripes-components/lib/global.css ./node_modules/@folio/stripes-core/src/index[39m[22m
      

      The error can be reproduced running 'yarn build' from the bulk-q4-update branch of platform-complete.

        TestRail: Results

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                malc John Malconian
                Reporter:
                malc John Malconian
                Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved:

                    TestRail: Runs

                      TestRail: Cases