Uploaded image for project: 'ui-checkin'
  1. ui-checkin
  2. UICHKIN-203

Snapshot no longer checking in 'Lost and paid' items on first attempt

    XMLWordPrintable

    Details

    • Template:
      Standard Bug Write-Up Format
    • Sprint:
      Core: F - Sprint 99, Core: F - Sprint 100, Core: F - Sprint 101
    • Story Points:
      0
    • Development Team:
      Prokopovych
    • Release:
      Q3 2020 Bug Fix

      Description

      Overview:
      Steps to Reproduce:

      1. Log into https://folio-snapshot.dev.folio.org/
      2. Check out an item to an patron and then let the item age to lost (making sure the Lost item fee policy in effect results in a Lost item fee)
      3. Item status with then be 'Aged to lost'
      4. Pay the Lost item fee in full
      5. Item status with then be 'Lost and paid'
      6. Check the item in
      7. Pop-up will ask you to confirm that you want to check in an item with 'Lost and paid' status
      8. Press Confirm button

      Expected Results:
      Item is checked in

      Actual Results:
      'No items have been entered' message
      Note: I have attached a recording showing what happens

      Additional Information:
      If you enter the barcode a second time, it will check in but it no longer has a status of 'Lost and paid'

        TestRail: Results

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                mpk35 Michal Kuklis
                Reporter:
                hollyolepm Holly Mistlebauer
                Tester Assignee:
                Holly Mistlebauer Holly Mistlebauer
                Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved:

                    TestRail: Runs

                      TestRail: Cases