Uploaded image for project: 'Stripes'
  1. Stripes
  2. STRIPES-734

Platform build failures: Cannot find module stripes-core/webpack/stripes-node-api

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: TBD
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Template:
    • Sprint:
      Prokopovych - Sprint 107
    • Story Points:
      1
    • Development Team:
      Prokopovych

      Description

      Today 2021-02-09 the hourly run of both platform-core and platform-complete snapshot branch are failing.

      The first failed run (https://jenkins-aws.indexdata.com/job/Automation/job/build-platform-core-snapshot/15556/console) was at 09:09 UTC (about 21 hours ago), and failing every hour since.

      It seems to be at the step where stripes-cli builds the front-end module descriptors:

      + yarn build-module-descriptors --strict
      yarn run v1.22.4
      $ stripes mod descriptor stripes.config.js --output ./ModuleDescriptors --strict
      Error: Cannot find module '@folio/stripes-core/webpack/stripes-node-api'
      ...
      

        TestRail: Results

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                zburke Zak_Burke
                Reporter:
                dcrossley David Crossley
                Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved:

                    TestRail: Runs

                      TestRail: Cases