Uploaded image for project: 'stripes-core'
  1. stripes-core
  2. STCOR-271

Selected panes in settings navigation are incorrectly highlighted after app switch

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: P3
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 2.4.0
    • Labels:
    • Template:

      Description

      If you navigate to a tertiary pane in settings (e.g., Developer -> Hotkeys Test), switch to a different app (not a different settings page – e.g., Items), and then switch back to Settings, the second and tertiary panes display the correct content – you're back where you started. However, the navigation highlighting is lost. The secondary pane always highlights the first item in the list, even if the second one is really what's being displayed, and the primary pane – the list of apps with settings – is missing a highlight altogether.

        TestRail: Results

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                mpk35 Michal Kuklis
                Reporter:
                mattjlc Matt Connolly
                Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved:

                    Time Tracking

                    Estimated:
                    Original Estimate - Not Specified
                    Not Specified
                    Remaining:
                    Remaining Estimate - 0 minutes
                    0m
                    Logged:
                    Time Spent - 15 minutes
                    15m

                      TestRail: Runs

                        TestRail: Cases