Uploaded image for project: 'RAML Module Builder'
  1. RAML Module Builder
  2. RMB-571

Remove com.google Guava runtime dependency

    XMLWordPrintable

Details

    • CP: Roadmap backlog
    • 3
    • Core: Platform

    Description

      16 files use Guava (com.google.*): https://github.com/folio-org/raml-module-builder/search?l=Java&p=2&q=%22com.google%22
      This results in a runtime dependency on Guava.
      org.raml.jaxrs:jaxrs-code-generator requires com.google.guava:guava 19.0 that contains a security vulnerability that is fixed in com.google.guava:guava >= 25.0. We cannot update to >= 25.0 because jaxrs-code-generator is incompatible with >= 25.0. See RMB-283.
      This also blocks making RMB OpenJDK 11 compliant, see RMB-328.

      Solution:
      Remove all com.google Guava runtime dependencies by replacing Guava by JDK 8 methods or by Apache Libraries (Commons, IO, ...) that we already include and use.

      Note: The com.google.common.cache.CacheStats returning methods should be removed. This is a breaking change but they are not used: https://github.com/search?q=org%3Afolio-org+cachestats&type=Code

      TestRail: Results

        Attachments

          Issue Links

            Activity

              People

                julianladisch Julian Ladisch
                julianladisch Julian Ladisch
                Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                  Created:
                  Updated:
                  Resolved:

                  TestRail: Runs

                    TestRail: Cases