Uploaded image for project: 'mod-source-record-manager'
  1. mod-source-record-manager
  2. MODSOURMAN-762

Supporting update SRM on envs

    XMLWordPrintable

Details

    • Folijet Sprint 137
    • 5
    • Folijet
    • Lotus R1 2022 Bug Fix
    • Related dependency upgrade

    Description

      We received information from RRT channel that some environments could not install new versions of SRM 3.3.3 - 3.3.6 and all time there are receiving ERROR message like this:

      id" : "mod-source-record-manager-3.3.4",
      "from" : "mod-source-record-manager-3.2.7",
      "action" : "enable",
      "message" : "Tenant operation failed for module mod-source-record-manager-3.3.4: SQL error\n DO $$ BEGIN\n ALTER TABLE IF EXISTS job_execution_source_chunks\n ADD CONSTRAINT job_execution_source_chunks_jobexecutionid_fkey FOREIGN KEY (jobexecutionid) REFERENCES job_execution(id);\nEXCEPTION\n WHEN duplicate_object THEN NULL;\nEND $$;\nERROR: column \"jobexecutionid\" referenced in foreign key constraint does not exist (42703)"

      envs:
      1. ttst, prod account, us-west-2 region
      2. lcon, int account, us-east-1 region

       bugfest upgrade goes without errors

      Interested parties: hleb_surnovich Rachana Murnal

      TestRail: Results

        Attachments

          Issue Links

            Activity

              People

                afedasiuk Aliaksandr Fedasiuk
                afedasiuk Aliaksandr Fedasiuk
                Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                  Created:
                  Updated:
                  Resolved:

                  TestRail: Runs

                    TestRail: Cases