Uploaded image for project: 'mod-permissions'
  1. mod-permissions
  2. MODPERMS-10

User-Created Permission Sets Not Working

    XMLWordPrintable

Details

    Description

      Overview: I created permissions sets and assigned them to users, but they aren't conferring access according to the contents of the sets

      Steps to repro:

      1. Log into demo test as diku_admin
      2. In Settings > Users, create a permission set "Can edit users and inventory all" - includes "can edit users" and "inventory all"
      3. Create a new user
      4. Assign the new permission to the new user
      5. Log out
      6. Log in as your newly-created user

      Expected results: Newly-created user's rights should be as if the individual permissions that make up the assigned custom set had been directly assigned

      Actual results: No app icons display at all (except Settings). It's as if the new user has no permissions at all.

      TestRail: Results

        Attachments

          Issue Links

            Activity

              People

                kurt Kurt Nordstrom
                cboerema Cate Boerema
                Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                  Created:
                  Updated:
                  Resolved:

                  Time Tracking

                    Estimated:
                    Original Estimate - Not Specified
                    Not Specified
                    Remaining:
                    Remaining Estimate - 0 minutes
                    0m
                    Logged:
                    Time Spent - 2 days, 2 hours
                    2d 2h

                    TestRail: Runs

                      TestRail: Cases