Uploaded image for project: 'mod-orders'
  1. mod-orders
  2. MODORDERS-245

Update API tests to use a user account with limited permissions

    XMLWordPrintable

Details

    • Story
    • Status: Closed (View Workflow)
    • P3
    • Resolution: Done
    • None
    • 6.0.0
    • None
    • ACQ Sprint 64
    • 1
    • Thunderjet

    Description

      Overview:
      We've run into problems several times now where orders placed via edge-orders/mod-gobi don't work as expected due to permission issues.

      In order to catch these problems earlier, we should update the API tests to utilize a user account with limited permissions as opposed to an admin user with "all" permissions.

      We've agreed as a team to do this, and have already done so in several other places. This story is specific to mod-orders API tests - If there are other places requiring these changes they will be handled in separate stories.

      Acceptance Criteria:

      • The mod-orders API tests are updated such that all tests requests are made as a user with limited permissions (only those required by mod-orders)

      TestRail: Results

        Attachments

          Issue Links

            Activity

              People

                KVupp Kruthi Vuppala
                cmcnally Craig McNally
                Craig McNally Craig McNally
                Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                  Created:
                  Updated:
                  Resolved:

                  TestRail: Runs

                    TestRail: Cases