FOLIO naming conventions for schemas dictate that camelCase is used for field names instead of under_score notation.
Since this is a brand new schema, we might as well fix this now.
- schema is updated
- examples are updated
- any code that is currently using this schema is updated (e.g. the submodule is updated and code fixes are applied as needed)
- this may only be mod-orders-storage, but depends on when this story is pulled.