Uploaded image for project: 'mod-oai-pmh'
  1. mod-oai-pmh
  2. MODOAIPMH-174

Goldenrod release version 3.0.1 fails to enable for tenant

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • P2
    • Resolution: Cannot Reproduce
    • None
    • None
    • None
    • Gulfstream Sprint 91
    • 0.5
    • Gulfstream

    Description

      On a fresh install with Goldenrod modules, enabling mod-oai-pmh-3.0.1 for a tenant fails with a NullPointerException

      HttpMethod: POST
      URL: https://<okapi-url>/_/proxy/tenants/<tenant-id>/install?tenantParameters=loadReference%3Dtrue%2CloadSample%3Dtrue
      Content-Type: application/json
      Accept: /
      X-Okapi-Tenant: supertenant
      Sending request to url: https://<okapi-url>/_/proxy/tenants/<tenant-id>/install?tenantParameters=loadReference%3Dtrue%2CloadSample%3Dtrue
      Response Code: HTTP/1.1 400 Bad Request

      400
      POST request for mod-oai-pmh-3.0.1 /_/tenant failed with 500: java.lang.NullPointerException

      This is all I could see in logs:

      [0m18:17:02.978 [vert.x-eventloop-thread-0] ERROR org.folio.rest.impl.ModTenantAPI - Cannot enable module: java.lang.NullPointerException
      

      TestRail: Results

        Attachments

          Issue Links

            Activity

              People

                energ1zr Dmytro Popov
                sduvvuri Sobha Duvvuri
                Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                  Created:
                  Updated:
                  Resolved:

                  TestRail: Runs

                    TestRail: Cases