Uploaded image for project: 'mod-login-saml'
  1. mod-login-saml
  2. MODLOGSAML-102

Remove xerces:xmlParserAPIs and xml-apis dependencies

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: TBD
    • Resolution: Done
    • Affects Version/s: 2.2.0
    • Fix Version/s: 2.2.1
    • Labels:
      None
    • Template:
      Standard Bug Write-Up Format
    • Sprint:
      CP: sprint 118
    • Story Points:
      0.5
    • Development Team:
      Core: Platform

      Description

      mod-login-saml has these dependencies:

      • xerces:xmlParserAPIs:2.6.2 via domain-models-runtime
      • xml-apis: xml-apis:1.3.04 via pac4j-saml-opensamlv3

      Both libraries haven been included into JDK since Java 9.

      Using any of these classes (org.w3c.dom.**) causes this compile error in Java compilers that comply with the Java specs (for example the one used by Eclipse):

      The package org.w3c.dom is accessible from more than one module: <unnamed>, java.xml

      Solution:

      Exclude these dependencies.

        TestRail: Results

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                julianladisch Julian Ladisch
                Reporter:
                julianladisch Julian Ladisch
                Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved:

                    TestRail: Runs

                      TestRail: Cases