Uploaded image for project: 'mod-inventory-storage'
  1. mod-inventory-storage
  2. MODINVSTOR-1026

Future.onComplete should be Future.compose in BoundWithAPI.java

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • P4
    • Resolution: Done
    • None
    • 26.0.0
    • None
    • Sif
    • Implementation coding issue

    Description

      https://github.com/folio-org/mod-inventory-storage/blob/82d902ea34276b764f4d055c9cca0487e802ff3a/src/main/java/org/folio/rest/impl/BoundWithAPI.java#L42-L76

      uses Future.onComplete. This doesn't handles failures.

      Future.compose should be used for proper failure handling. This also avoid the 17 levels of indentation that makes the code hard to read and understand.

      All failure handling should be combined and handled at the end using a single .onFailure call. This avoid duplicate code.

      TestRail: Results

        Attachments

          Issue Links

            Activity

              People

                julianladisch Julian Ladisch
                julianladisch Julian Ladisch
                Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                  Created:
                  Updated:
                  Resolved:

                  TestRail: Runs

                    TestRail: Cases