Uploaded image for project: 'mod-invoice'
  1. mod-invoice
  2. MODINVOICE-217

Folio testing build fails due to incompatible invoice-storage.invoices dependency

    XMLWordPrintable

Details

    • Standard Bug Write-Up Format
    • ACQ Sprint 103
    • 1
    • Thunderjet

    Description

      Overview:

      mod-invoice-4.2.0-SNAPSHOT.180 requires invoice-storage.invoices 4.1 however mod-invoice-storage-4-2-0.SNAPSHOT.82 provides invoice-storage.invoices 5.0

      Steps to Reproduce:

      Expected Results: Successful build of folio-testing with latest module versions
      Actual Results: Failed build, with the following error: Incompatible version for module mod-invoice-4.2.0-SNAPSHOT.180 interface invoice-storage.invoices. Need 4.1. Have 5.0/mod-invoice-storage-4.2.0-SNAPSHOT.82
      Additional Information: Breaking compatible interface changes are intended to be merged together with updates to all dependencies in the hosted environments

      These changes were announced on Slack recently
      URL: https://jenkins-aws.indexdata.com/job/FOLIO_Reference_Builds/job/folio-testing-backend/730/console
      Interested parties: Andrei_Makaranka zburke malc ian dcrossley wayne

      TestRail: Results

        Attachments

          1. screenshot-1.png
            100 kB
            Andrei Makaranka

          Issue Links

            Activity

              People

                Andrei_Makaranka Andrei Makaranka
                marcjohnson Marc Johnson
                Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                  Created:
                  Updated:
                  Resolved:

                  TestRail: Runs

                    TestRail: Cases