Uploaded image for project: 'mod-inventory'
  1. mod-inventory
  2. MODINV-471

Ensure "version" property while updating holdings record using the data-import

    XMLWordPrintable

    Details

    • Template:
    • Story Points:
      0.5
    • Development Team:
      Folijet
    • Release:
      R3 2021

      Description

      During the investigation of MODDATAIMP-496 such a message was observed in the mod-inventory-storage log on holdings record update using data-import

      14:27:58 [] [] [] [] WARN  ?                    Backend notice: severity='NOTICE', code='23F09', message='Ignoring optimistic locking conflict while overwriting changed record fbad6996-f827-498c-8512-92e10e9f8c6b: Stored _version is 1, _version of request is <NULL>', detail='null', hint='null', position='null', internalPosition='null', internalQuery='null', where='PL/pgSQL function holdings_record_set_ol_version() line 8 at RAISE', file='pl_exec.c', line='3862', routine='exec_stmt_raise', schema='diku_mod_inventory_storage', table='holdings_record', column='null', dataType='null', constraint='null'
      

      Ensure request to holdings record update with "version" property while updating holdings through data-import to avoid warnings in the module log

        TestRail: Results

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                ruslan_lavrov Ruslan Lavrov
                Reporter:
                ruslan_lavrov Ruslan Lavrov
                Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved:

                    TestRail: Runs

                      TestRail: Cases