Uploaded image for project: 'mod-graphql'
  1. mod-graphql
  2. MODGQL-142

Update node.js version from 10 to 14

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • TBD
    • Resolution: Done
    • 1.9.0
    • None
    • None
    • Thor

    Description

      The Jenkins build pipeline of the pull request https://github.com/folio-org/mod-graphql/pull/65 fails with this error message:

      error incoming-message-hash@4.1.0: The engine "node" is incompatible with this module. Expected version ">=12". Got "10.24.1"
      error Found incompatible module. 

      https://jenkins-aws.indexdata.com/blue/organizations/jenkins/folio-org%2Fmod-graphql/detail/MODGQL-141-json-ptr-3.0.0/2/pipeline/

      https://jenkins-aws.indexdata.com/blue/organizations/jenkins/folio-org%2Fmod-graphql/detail/PR-65/1/pipeline/

      Solution: Switch node.js version from 10 to 14. FOLIO usually uses node.js 14.

      TestRail: Results

        Attachments

          Issue Links

            Activity

              People

                mike Mike Taylor
                julianladisch Julian Ladisch
                Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                  Created:
                  Updated:
                  Resolved:

                  TestRail: Runs

                    TestRail: Cases