Uploaded image for project: 'mod-feesfines'
  1. mod-feesfines
  2. MODFEE-164

Refund report fails when automatic refunds exist

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: TBD
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None
    • Template:
    • Sprint:
      EPAM-Veg Sprint 106, EPAM-Veg Sprint 107
    • Story Points:
      3
    • Development Team:
      Vega
    • Confidence factor:
      Medium

      Description

      Steps to reproduce:

      1. Set up a Lost item policy to charge Lost item fee or Lost item processing fee
      2. Check-out an item
      3. Go to loan, declare the item lost
      4. Make sure Lost item fee or Lost item processing fee is created
      5. Pay it fully or partially
      6. Check-in the item and make sure the payment was refunded
      7. Run a report (Users->Actions->Refunds to process manually)

      Expected result:
      Report starts downloading

      Actual result:
      Internal server error from /feefine-reports/refund endpoint.

        TestRail: Results

          Attachments

            Activity

              People

              Assignee:
              Illia Dolzhenko Illia Dolzhenko
              Reporter:
              oleksandrkurash Alexander Kurash
              Tester Assignee:
              Holly Mistlebauer Holly Mistlebauer
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  TestRail: Runs

                    TestRail: Cases