Uploaded image for project: 'mod-data-import-converter-storage'
  1. mod-data-import-converter-storage
  2. MODDICONV-75

Fix security vulnerabilities reported in jackson-databind >= 2.0.0, < 2.9.9.2

    XMLWordPrintable

    Details

    • Template:
    • Development Team:
      Folijet

      Description

      Remediation

      Upgrade com.fasterxml.jackson.core:jackson-databind to version 2.9.9.2 or later. For example:

      <dependency>
       <groupId>com.fasterxml.jackson.core</groupId>
       <artifactId>jackson-databind</artifactId>
       <version>[2.9.9.2,)</version>
      </dependency>
      

      Always verify the validity and compatibility of suggestions with your codebase.

      Details

      CVE-2019-14379

      moderate severity
      *Vulnerable versions:* < 2.9.9.2
      *Patched version:* 2.9.9.2

      SubTypeValidator.java in FasterXML jackson-databind before 2.9.9.2 mishandles default typing when ehcache is used, leading to remote code execution.

      CVE-2019-14439

      moderate severity
      *Vulnerable versions:* < 2.9.9.2
      *Patched version:* 2.9.9.2

      A Polymorphic Typing issue was discovered in FasterXML jackson-databind 2.x before 2.9.9.2. This occurs when Default Typing is enabled (either globally or for a specific property) for an externally exposed JSON endpoint and the service has the logback jar in the classpath.

        TestRail: Results

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                Unassigned Unassigned
                Reporter:
                peter Peter Murray
                Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved:

                    TestRail: Runs

                      TestRail: Cases