Uploaded image for project: 'mod-courses'
  1. mod-courses
  2. MODCR-59

align dependency versions affected by Inventory's Optimistic Locking

    XMLWordPrintable

    Details

    • Type: Story
    • Status: Closed (View Workflow)
    • Priority: P2
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 1.2.3
    • Labels:
      None
    • Template:
    • Sprint:
      CP: sprint 115, CP: sprint 116
    • Story Points:
      1
    • Development Team:
      Core: Platform

      Description

      According to Okapi dependency graph:

      http://localhost:9130/_/proxy/modules?require=item-storage,item-storage-batch-sync,holdings-storage,holdings-storage-batch-sync,instance-storage,instance-storace-batch,instance-storage-batch-sync&latest=1

      this module depends on one of the Inventory's interfaces that requires a major version change due to introduction of Optimistic Locking (see MODINV-398 and MODINVSTOR-726).

      The new dependency should support both version: previous and new one.

        TestRail: Results

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                julianladisch Julian Ladisch
                Reporter:
                jakub Jakub Skoczen
                Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved:

                    TestRail: Runs

                      TestRail: Cases