Uploaded image for project: 'mod-configuration'
  1. mod-configuration
  2. MODCONF-85

Cannot enable mod-configuration

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • TBD
    • Resolution: Done
    • 5.6.0
    • None
    • None
    • None

    Description

      Overview:

      Working on a clean install of Iris on kubernetes (AWS EKS using RDS), when I go to enable modules I get the the error `"cubl_mod_configuration.rmb_job" does not exist` when trying to enable `mod_configuration`.

      Steps to Reproduce:

      1. Create new instance of okapi
      2. Create a new tenant and enable okapi
      3. Deploy module containers and register module/deployment descriptors in the supertenant (one at a time in a loop)
      4. Enable modules one at a time by posting to `_/proxy/tenants/TENANT/install?deploy=false&tenantParameters=loadSample=true,loadReference=true`

      Expected Results:

      Module should enable
      Actual Results:

      400 Error from OKAPI, complete log from mod-configuration container is attached.

      Additional Information:
      URL:
      Interested parties:
      University of Colorado Boulder

      TestRail: Results

        Attachments

          Activity

            People

              adam Adam Dickmeiss
              jwfuller James Fuller
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                TestRail: Runs

                  TestRail: Cases