Uploaded image for project: 'liquibase-util'
  1. liquibase-util
  2. LIQUTIL-26

Vert.x 4.3.3, PostgreSQL 42.5.0 fixing vulns; bump RMB, Liquibase, JUnit

    XMLWordPrintable

Details

    • 0
    • Folijet Support
    • Morning Glory (R2 2022) Bug Fix
    • Third party component integration

    Description

      Upgrade Vert.x from 4.3.1 to 4.3.3 fixing disabled SSL: https://github.com/vert-x3/wiki/wiki/4.3.2-Release-Notes#vertx-web

      Upgrade postgresql JDBC driver from 42.3.3 to 42.5.0 fixing SQL Injection: https://nvd.nist.gov/vuln/detail/CVE-2022-31197

      Upgrade RMB from 34.0.0 to 34.0.2 to match the new Vert.x version.

      Upgrade liquibase from 4.9.0 to 4.15.0.

      Upgrade JUnit from 4.13.1 to 4.13.2.

      TestRail: Results

        Attachments

          Issue Links

            Activity

              People

                julianladisch Julian Ladisch
                julianladisch Julian Ladisch
                Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                  Created:
                  Updated:
                  Resolved:

                  TestRail: Runs

                    TestRail: Cases