Uploaded image for project: 'FOLIO'
  1. FOLIO
  2. FOLIO-1687

Security vulnerability reported in okapi-cli for vertx-web < 3.5.3, vertx-core < 3.5.4

    XMLWordPrintable

    Details

    • Template:

      Description

      For https://github.com/folio-org/okapi-cli, GitHub reports these two security vulnerabilities in pom.xml.

      Dependency: io.vertx:vertx-web with version >= 3.0.0, < 3.5.3

      Proposed solution: Upgrade to ~> 3.5.3

      Vulnerabilities:
      CVE-2018-12540 High severity
      CVE-2018-12542 Low severity

      Dependency: io.vertx:vertx-core with version >= 3.0.0, < 3.5.4

      Proposed solution: Upgrade to ~> 3.5.4

      Vulnerabilities:
      CVE-2018-12541 Low severity
      CVE-2018-12537 Moderate severity

        TestRail: Results

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                Unassigned Unassigned
                Reporter:
                peter Peter Murray
                Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved:

                    TestRail: Runs

                      TestRail: Cases