Uploaded image for project: 'FOLIO'
  1. FOLIO
  2. FOLIO-1513

/perms/ returns a 404 for some users

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: P2
    • Resolution: Done
    • Component/s: None
    • Labels:
    • Template:

      Description

      Description:

      The /perms/ endpoint in the Q3 release at http://folio-q3.aws.indexdata.com returns a 404 for some users even though those users exist.

      Steps to reproduce:

      Expected behavior:

      • The detail record displays without error

      Actual behavior:

      • The detail record displays
      • The app reports an Okapi error in a javascript alert box: "ERROR in module @folio/users, operation GET on resource 'permissions' failed, saying: No user found by id 72069..."

      Additional information

      The network inspector shows the following request returns a 404: http://folio-q3.aws.indexdata.com:9130/perms/users/720694a0-cd30-414f-a085-befffa3d0b89/permissions?full=true&indexField=userId.

        TestRail: Results

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                malc John Malconian
                Reporter:
                zburke Zak_Burke
                Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved:

                    TestRail: Runs

                      TestRail: Cases