Uploaded image for project: 'mod-circulation'
  1. mod-circulation
  2. CIRC-1189

Incorrect error message, Aged to lost discharge

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • P2
    • Resolution: Cannot Reproduce
    • None
    • None
    • Prokopovych
    • Cornell, TAMU

    Description

      Overview:

      staff had requested a report of items that were lost when discharged, so I was experimenting with setting up a condition to create that report. I found an item in our Iris release that was migrated as "aged to lost" and suppressed to discovery. When I 1st discharged it, I received the normal discharge warning that it was a lost item. After I clicked the "confirm" button on that pop up, I got a 2nd message pop up saying that the item was not discharged, that it was lost, but that there was no aged to lost or declared lost found. Since it said it had not discharged it, I double checked it in inventory and its status in inventory is "Available". The sequence is reproduced in the screenshots that are attached to this issue.
      Steps to Reproduce:

      1. Identify an "Aged to lost" item.
      2. Check it in and confirm checkin.

      Expected Results:

      System discharges item with warning that the item had an Aged to lost status.
      Actual Results:

      System warns that item is not discharged and it still lost, but discharges it anyway.
      Additional Information:
      URL:
      Interested parties:

      TestRail: Results

        Attachments

          Issue Links

            Activity

              People

                hollyolepm Holly Mistlebauer
                hismith Anne L. Highsmith
                Votes:
                1 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                  Created:
                  Updated:
                  Resolved:

                  TestRail: Runs

                    TestRail: Cases